Temporary SMS delivery issues

Incident Report for Sumsub

Postmortem

Incident Timings

Start time: 23 Feb 07:00 UTC
End time: 24 Feb 14:00 UTC

Incident Summary

Some of our clients reported a decline in SMS delivery rates. After switching to the fallback SMS sending method, delivery remained stable for some time but began declining again after several hours. As a result, a small portion of applicants were unable to complete verification because they did not receive SMS notifications. Once the underlying issue was identified and resolved, our team ensured that no further action was required from clients. Affected applicants can complete the verification process by simply retrying the SMS step.

Root Cause

A significant volume of untracked SMS messages caused by a technical issue. These messages were sent in unusual way, allowing to bypass both our system’s and the SMS provider’s rate-limiting mechanisms. This resulted in an unusually high spike in message traffic, leading to message queues, with some messages timing out and not being delivered.

Action Plan

As a result of this issue, our Team has identified several key areas for improvement:

  1. Enhance Monitoring & Visibility: Improve alerting for SMS delivery
  2. Prevent Recurrence: Enhance rate limiting and throttling
  3. Collaborate with SMS providers: Coordinate with our SMS service providers to improve anomaly detection mechanisms from their side and introduce additional fallback options

Conclusion

If you are still experiencing any unusual SMS delivery rate fluctuations or if you have any questions or concerns please contact our Support Team.

Posted Feb 25, 2025 - 15:42 UTC

Resolved

After several hours of extensive monitoring and testing, issue is confirmed to be resolved.

Our Team has conducted additional series of checks and tests to ensure the delivery remains stable.

If you have any further issues or questions, please contact Sumsub Support!
Posted Feb 24, 2025 - 17:34 UTC

Monitoring

We are happy to report that SMS delivery issues have been resolved and we are now actively monitoring the system to ensure stability.

Thank you for your patience.

Please reach out to Sumsub Support if you experience any further issues.
Posted Feb 24, 2025 - 14:27 UTC

Investigating

We are currently experiencing temporary SMS delivery issues affecting some users. Our team is actively investigating the issue and working with SMS service providers to resolve the issue as quickly as possible.

We apologize for any inconvenience this may cause and appreciate your patience. Updates will be provided as soon as more information is available.

Thank you for your understanding.
Posted Feb 24, 2025 - 10:32 UTC
This incident affected: API, WebSDK, and MobileSDK.