Temporary ticketing system outage

Incident Report for Sumsub

Resolved

The infrastructure provider confirmed an incident and currently investigating the root cause. Ticketing functionality is restored, all previous messages can be resubmitted and processed by the support team.
Posted May 28, 2026 - 19:06 UTC

Investigating

Our Support systems are currently experiencing outage caused by a failure at our infrastructure provider. As a result, all messaging channels and ticketing workflows are unavailable.

Slack, Telegram and Dashboard chats are non-functional. Messages are not reaching Support Team.
Ticket creation — blocked. New tickets cannot be created via any channel.
Existing ticket replies — not visible to the support team. Customer replies on open tickets are not appearing in our systems

The issue is on the provider's side and is outside our control.
Although no ETA available at this time, we are actively investigating with our provider to return service back to operational state.
Posted May 28, 2026 - 17:39 UTC
This incident affected: Support Systems.