AML verifications disruption

Incident Report for Sumsub

Resolved

We can confirm that the technical issues with our AML verification provider have been fully resolved.

All systems are fully operational, and any delayed verifications have now been successfully processed.

If you have any questions or need further assistance, please don’t hesitate to contact our support team.
Posted Sep 10, 2025 - 14:30 UTC

Monitoring

The technical issues with our AML verification provider have reportedly been resolved.

We are closely monitoring the situation to ensure stable performance and working to minimize any remaining impact.
Posted Sep 10, 2025 - 14:18 UTC

Identified

Our external service provider for AML verifications is currently experiencing technical issues.

As a result, some verifications may take longer than usual until the issue is resolved.

Our team is working closely with the AML provider to investigate the incident, and we will share further updates as soon as they become available.
Posted Sep 10, 2025 - 14:08 UTC
This incident affected: API, WebSDK, and MobileSDK.