Support Ticketing System Disruption

Incident Report for Sumsub

Resolved

The issue affecting our support ticketing system has been fully resolved.
The disruption was caused by a temporary outage on the side of an external provider, which has now been restored to normal service.
All incoming support tickets are being received and processed as expected.
Posted Nov 19, 2025 - 18:03 UTC

Update

We are continuing to investigate this issue.
Posted Nov 19, 2025 - 18:01 UTC

Investigating

We are currently experiencing an issue with our support ticketing system. New tickets cannot be submitted, received, or processed at the moment.
Our team is actively investigating the issue and working toward a resolution. Further updates will be provided as soon as more details are available.
Thanks for your patience and understanding!
Posted Nov 19, 2025 - 17:19 UTC