Possible Request Timeouts Notice
Incident Report for Sumsub
Postmortem

Post an extensive investigation conducted by the Sumsub Team, the following conclusions have been reached:

  • The incident has only impacted the performance of requests to api.sumsub.com and caused no downtime.
  • The issue was caused by a network stack failure in one of the database cluster nodes.
  • The affected node has been phased out from production for further diagnostics.

As of now, the performance of api.sumsub.com remains optimal. The problematic node has been replaced.

Our team will incorporate lessons learned from this incident into our next review of redundancy protocols.

Posted May 13, 2024 - 19:01 UTC

Resolved
We are happy to announce that the issue is considered as fully resolved.

Our Team has conducted additional series of checks and tests to ensure the issue is fixed.

We do confirm that service performance remains perfect and there is no impact on service operation.

Thank you for your patience!
Posted May 13, 2024 - 16:37 UTC
Monitoring
We are pleased to inform you that the problem was succesfully mitigated. You can expect no further impact on our services' performance.

Our team is still continuing to monitor the situation and does additional investigation of the issue.

We will continue to monitor the system closely for the next 30 minutes to ensure stability and optimal performance.

Should there be any further issues, we will take immediate action and provide you with an update.
Posted May 13, 2024 - 15:43 UTC
Investigating
We're currently investigating possible timeouts of requests to our services.

Our team is actively working to identify the root cause and resolve the issue with the highest priority.
We apologize for any inconvenience this may cause and are currently doing our best to resolve this as quickly and safely as possible.
We will continue to monitor the situation and provide another update in 30 minutes, or sooner if there are any significant changes.
Posted May 13, 2024 - 15:18 UTC
This incident affected: API, WebSDK, and MobileSDK.