Delayed Liveness Initialization in WebSDK

Incident Report for Sumsub

Resolved

After review, no widespread or systemic issue was identified. A small number of isolated user reports indicated slower-than-usual loading times when accessing the liveness verification screen.

The service remained fully available throughout the reported period. Overall system performance was stable, and the behavior appears to have been limited to individual cases rather than a broader service impact.

Those reports will be investigated and fixed individually.

Please contact Sumsub Support in case you have any questions!
Posted Dec 10, 2025 - 17:50 UTC

Investigating

Some of clients reported unusually long loading times when accessing the liveness verification screen.

In some cases, the screen took several minutes to appear, impacting the overall user experience during the verification process when using WebSDK.

Our Team is currently investigating the matter.

The service remains fully operational.
Posted Dec 10, 2025 - 17:38 UTC
This incident affected: WebSDK.